blob: 05ded76597ae9df3c06d7d4900db2fc77c195331 [file] [log] [blame]
Patrick Venture7ebe0262018-03-30 11:23:16 -07001SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
Patrick Venture6b91f732018-09-28 19:21:26 -07003HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
Patrick Venture6b91f732018-09-28 19:21:26 -07004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture7ebe0262018-03-30 11:23:16 -07006DEPENDS += "sdbusplus"
Kun Yi41d3e4d2018-09-12 11:01:33 -07007DEPENDS += "sdeventplus"
Patrick Venture7ebe0262018-03-30 11:23:16 -07008DEPENDS += "phosphor-dbus-interfaces"
9DEPENDS += "systemd"
Kumar Thangavel18fa3832021-08-18 18:04:45 +053010DEPENDS += "libgpiod"
Ed Tanous9936f862022-09-19 09:13:20 -070011SRCREV = "aee6540154f2ac8ea510efacd2785868c1898a7d"
12PACKAGECONFIG ?= ""
13PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
14PV = "0.1+git${SRCPV}"
15PR = "r1"
16
17SRC_URI = "git://github.com/openbmc/phosphor-host-postd;branch=master;protocol=https"
Patrick Venture7ebe0262018-03-30 11:23:16 -070018
Patrick Venture6b91f732018-09-28 19:21:26 -070019S = "${WORKDIR}/git"
Benjamin Fair89e86cd2018-06-29 13:00:14 -070020SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
Benjamin Fair89e86cd2018-06-29 13:00:14 -070021SERVICE_FILE = "lpcsnoop.service"
Patrick Venture20b4af62018-10-23 11:57:36 -070022SYSTEMD_PACKAGES = "${PN}"
Patrick Williams12fc9392021-08-06 09:16:53 -050023SYSTEMD_SERVICE:${PN} += "${SERVICE_FILE}"
Ed Tanous9936f862022-09-19 09:13:20 -070024SERVICE_FILE_7SEG = " \
25 postcode-7seg@.service \
26 postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
27"
28SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"
29
30inherit meson
31inherit pkgconfig
32inherit systemd
Patrick Venture20b4af62018-10-23 11:57:36 -070033
Patrick Williamsed104d42021-08-31 13:19:27 -050034EXTRA_OEMESON:append = " \
35 -Dsnoop-device=${SNOOP_DEVICE} \
36 -Dpost-code-bytes=${POST_CODE_BYTES} \
Zev Weiss9aa92482022-04-05 17:40:10 -070037 -Dtests=disabled \
Patrick Williamsed104d42021-08-31 13:19:27 -050038"
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070039
Ed Tanous9936f862022-09-19 09:13:20 -070040POST_CODE_BYTES ?= "1"
417SEG_GPIO ?= "0"
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070042POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"