blob: 5971dd000f68dfd0f2193b1b94fd49f75b4ac763 [file] [log] [blame]
Patrick Williams9e206392017-01-19 21:20:46 -06001SUMMARY = "Phosphor State Management"
2DESCRIPTION = "Phosphor State Manager provides a set of system state \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
6PR = "r1"
Patrick Venturedcb29962018-10-21 08:23:40 -07007PV = "1.0+git${SRCPV}"
Patrick Williams9e206392017-01-19 21:20:46 -06008LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
Andrew Geissler20cff702020-03-09 16:51:27 -050011include phosphor-state-manager-systemd-links.inc
12
Patrick Williams9e206392017-01-19 21:20:46 -060013STATE_MGR_PACKAGES = " \
14 ${PN}-host \
15 ${PN}-chassis \
Josh Kingd2b95c72017-01-19 14:04:03 -060016 ${PN}-bmc \
Andrew Geisslerb2644f82021-02-10 16:11:58 -060017 ${PN}-hypervisor \
Michael Tritzb6e965c2017-04-18 17:01:12 -050018 ${PN}-discover \
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050019 ${PN}-host-check \
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060020 ${PN}-reset-sensor-states \
Andrew Geissler44cadef2019-09-23 19:11:20 +000021 ${PN}-systemd-target-monitor \
Andrew Geissler024c25d2020-01-14 14:21:24 -060022 ${PN}-obmc-targets \
Andrew Geissler98d98042020-04-15 16:02:17 +000023 ${PN}-scheduled-host-transition \
Patrick Williams9e206392017-01-19 21:20:46 -060024"
Brad Bishop7f9102c2018-04-11 11:44:15 -040025PACKAGE_BEFORE_PN += "${STATE_MGR_PACKAGES}"
26ALLOW_EMPTY_${PN} = "1"
Brad Bishop1a5a5972017-03-01 16:08:45 -050027
Patrick Williams9e206392017-01-19 21:20:46 -060028DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
29
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060030SYSTEMD_PACKAGES = "${PN}-discover \
31 ${PN}-reset-sensor-states \
Andrew Geissler44cadef2019-09-23 19:11:20 +000032 ${PN}-systemd-target-monitor \
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060033"
Andrew Geissler6bc2f022018-03-13 11:46:27 -070034
35# The host-check function will check if the host is running
36# after a BMC reset.
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060037# The reset-sensor-states function will reset the host
Andrew Geissler6bc2f022018-03-13 11:46:27 -070038# sensors on a BMC reset or system power loss.
39# Neither is required for host state function but are
40# recommended to deal properly with these reset scenarios.
41RRECOMMENDS_${PN}-host = "${PN}-host-check ${PN}-reset-sensor-states"
Patrick Williams9e206392017-01-19 21:20:46 -060042
Andrew Geissler024c25d2020-01-14 14:21:24 -060043# The obmc-targets are the base targets required to boot a computer system
44RRECOMMENDS_${PN}-host += "${PN}-obmc-targets"
45
Andrew Geisslerae3fe4a2019-12-11 14:51:20 -060046inherit meson pkgconfig
Patrick Williams9e206392017-01-19 21:20:46 -060047inherit obmc-phosphor-dbus-service
Andrew Geissler15834fd2020-03-09 16:59:22 -050048inherit obmc-phosphor-systemd
Patrick Williams9e206392017-01-19 21:20:46 -060049
Patrick Williams9e206392017-01-19 21:20:46 -060050DEPENDS += "sdbusplus"
William A. Kennington IIIfa391f22018-10-18 01:34:43 -070051DEPENDS += "sdeventplus"
Patrick Williams9e206392017-01-19 21:20:46 -060052DEPENDS += "phosphor-logging"
Patrick Williams1815f6b2017-01-30 11:06:16 -060053DEPENDS += "phosphor-dbus-interfaces"
Brad Bishop17c08bf2018-10-18 17:07:53 -040054DEPENDS += "libcereal"
Andrew Geissler44cadef2019-09-23 19:11:20 +000055DEPENDS += "nlohmann-json"
56DEPENDS += "cli11"
Patrick Williams9e206392017-01-19 21:20:46 -060057
Anthony Wilsoncd800c82019-03-30 08:11:32 -070058FILES_${PN}-host = "${bindir}/phosphor-host-state-manager"
Patrick Williams9e206392017-01-19 21:20:46 -060059DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service"
Andrew Geissler4ec27742017-07-26 17:53:04 -050060DBUS_SERVICE_${PN}-host += "phosphor-reboot-host@.service"
Andrew Geisslerec7f9202018-03-27 19:39:05 -070061SYSTEMD_SERVICE_${PN}-host += "phosphor-reset-host-reboot-attempts@.service"
Andrew Geisslerb05ebce2020-11-04 16:41:45 +000062SYSTEMD_SERVICE_${PN}-host += "phosphor-clear-one-time@.service"
Andrew Geissler4ef0e112021-01-05 16:51:58 -060063SYSTEMD_SERVICE_${PN}-host += "phosphor-set-host-transition-to-running@.service"
64SYSTEMD_SERVICE_${PN}-host += "phosphor-set-host-transition-to-off@.service"
Patrick Williams9e206392017-01-19 21:20:46 -060065
Anthony Wilsoncd800c82019-03-30 08:11:32 -070066FILES_${PN}-chassis = "${bindir}/phosphor-chassis-state-manager"
Patrick Williams9e206392017-01-19 21:20:46 -060067DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service"
68
Anthony Wilsoncd800c82019-03-30 08:11:32 -070069FILES_${PN}-chassis += "${bindir}/obmcutil"
70
71FILES_${PN}-bmc = "${bindir}/phosphor-bmc-state-manager"
Josh Kingd2b95c72017-01-19 14:04:03 -060072DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service"
73
Andrew Geisslerb2644f82021-02-10 16:11:58 -060074FILES_${PN}-hypervisor = "${bindir}/phosphor-hypervisor-state-manager"
75DBUS_SERVICE_${PN}-hypervisor += "xyz.openbmc_project.State.Hypervisor.service"
76
Anthony Wilsoncd800c82019-03-30 08:11:32 -070077FILES_${PN}-discover = "${bindir}/phosphor-discover-system-state"
Michael Tritzb3b58992017-03-31 12:04:32 -050078SYSTEMD_SERVICE_${PN}-discover += "phosphor-discover-system-state@.service"
79
Anthony Wilsoncd800c82019-03-30 08:11:32 -070080FILES_${PN}-host-check = "${bindir}/phosphor-host-check"
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050081SYSTEMD_SERVICE_${PN}-host-check += "phosphor-reset-host-check@.service"
82SYSTEMD_SERVICE_${PN}-host-check += "phosphor-reset-host-running@.service"
83
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060084SYSTEMD_SERVICE_${PN}-reset-sensor-states += "phosphor-reset-sensor-states@.service"
85
Andrew Geissler44cadef2019-09-23 19:11:20 +000086FILES_${PN}-systemd-target-monitor = " \
87 ${bindir}/phosphor-systemd-target-monitor \
88 ${sysconfdir}/phosphor-systemd-target-monitor/phosphor-target-monitor-default.json \
89 "
90SYSTEMD_SERVICE_${PN}-systemd-target-monitor += "phosphor-systemd-target-monitor.service"
91
Andrew Geissler98d98042020-04-15 16:02:17 +000092FILES_${PN}-scheduled-host-transition = "${bindir}/phosphor-scheduled-host-transition"
93DBUS_SERVICE_${PN}-scheduled-host-transition += "xyz.openbmc_project.State.ScheduledHostTransition.service"
94
Andrew Geissler024c25d2020-01-14 14:21:24 -060095# Chassis power synchronization targets
96# - start-pre: Services to run before we start power on process
97# - start: Services to run to do the chassis power on
98# - on: Services to run once power is on
99# - stop-pre,stop,off: Same as above but applied to powering off
100# - reset-on: Services to check if chassis power is on after bmc reset
101CHASSIS_SYNCH_TARGETS = "start-pre start on stop-pre stop off reset-on"
102
103# Chassis action power targets
104# - on: Services to run to power on the chassis
105# - off: Services to run to power off the chassis
106# - powered-off: Services to run once chassis power is off
107# - reset: Services to check chassis power state and update chassis "on" target
108# - hard-off: Services to force an immediate power off of the chassis
109CHASSIS_ACTION_TARGETS = "poweron poweroff powered-off powerreset hard-poweroff"
110
111# Track all host synchronization point targets
112# - start-pre: Services to run before we start host boot
113# - starting: Services to run to do the host boot
114# - started: Services to run once the host is booted
115# - stop-pre,stopping,stopped: Same as above but applied to shutting down the host
116# - reset-running: Services to check if host is running after bmc reset
117HOST_SYNCH_TARGETS = "start-pre starting started stop-pre stopping stopped reset-running"
118
119# Track all host action targets
120# - start: Will run startmin target, this target used for any additional
121# services that user needs for an initial power on of host.
122# For example, resetting the host reboot count could be put in
123# this target so on any fresh power on, this count is reset.
124# - startmin: Minimum services required to start the host. This target will
125# be called by reboot and start target.
126# - stop: Services to run to shutdown the host
127# - quiesce: Target to enter on host boot failure
128# - shutdown: Tell host to shutdown, then stop system
129# - reset: Services to check if host is running and update host "start" target
130# - crash: Target to run when host crashes. it is very much similar to
131# quiesce target but the only delta is that this target contains
132# multiple services and one of them is the quiesce target.
133# - timeout: Target to run when host watchdog times out
Andrew Geisslerbbe378e2020-02-10 13:47:12 -0600134# - reboot: Reboot the host with a chassis power cycle included
135# - warm-reboot: Reboot the host without a chassis power cycle.
136# - force-warm-reboot: Reboot the host without a chassis power cycle and without
137# notifying the host.
138# - diagnostic-mode: This will be entered when the host is collecting diagnostic
139# data for itself.
140HOST_ACTION_TARGETS = "start startmin stop quiesce reset shutdown crash timeout "
141HOST_ACTION_TARGETS += "reboot warm-reboot force-warm-reboot diagnostic-mode"
Andrew Geissler024c25d2020-01-14 14:21:24 -0600142
143CHASSIS_SYNCH_FMT = "obmc-power-{0}@.target"
144CHASSIS_ACTION_FMT = "obmc-chassis-{0}@.target"
145HOST_SYNCH_FMT = "obmc-host-{0}@.target"
146HOST_ACTION_FMT = "obmc-host-{0}@.target"
147
148CHASSIS_LINK_SYNCH_FMT = "${CHASSIS_SYNCH_FMT}:obmc-power-{0}@{1}.target"
149CHASSIS_LINK_ACTION_FMT = "${CHASSIS_ACTION_FMT}:obmc-chassis-{0}@{1}.target"
150HOST_LINK_SYNCH_FMT = "${HOST_SYNCH_FMT}:obmc-host-{0}@{1}.target"
151HOST_LINK_ACTION_FMT = "${HOST_ACTION_FMT}:obmc-host-{0}@{1}.target"
152FAN_LINK_FMT = "obmc-fan-control-ready@.target:obmc-fan-control-ready@{0}.target"
153
154# Targets to be executed on checkstop and watchdog timeout
Andrew Geissler91685cd2020-12-17 14:23:10 -0600155HOST_ERROR_TARGETS = "timeout"
Andrew Geissler024c25d2020-01-14 14:21:24 -0600156
157QUIESCE_TMPL = "obmc-host-quiesce@.target"
158CRASH_TIMEOUT_TGTFMT = "obmc-host-{0}@{1}.target"
159QUIESCE_INSTFMT = "obmc-host-quiesce@{1}.target"
160QUIESCE_FMT = "../${QUIESCE_TMPL}:${CRASH_TIMEOUT_TGTFMT}.wants/${QUIESCE_INSTFMT}"
161
162SYSTEMD_SERVICE_${PN}-obmc-targets += " \
163 obmc-mapper.target \
164 obmc-fans-ready.target \
165 obmc-fan-control.target \
166 obmc-fan-control-ready@.target \
167 obmc-fan-watchdog-takeover.target \
168 "
169
170SYSTEMD_SERVICE_${PN}-obmc-targets += "${@compose_list(d, 'CHASSIS_SYNCH_FMT', 'CHASSIS_SYNCH_TARGETS')}"
171SYSTEMD_SERVICE_${PN}-obmc-targets += "${@compose_list(d, 'CHASSIS_ACTION_FMT', 'CHASSIS_ACTION_TARGETS')}"
172SYSTEMD_SERVICE_${PN}-obmc-targets += "${@compose_list(d, 'HOST_SYNCH_FMT', 'HOST_SYNCH_TARGETS')}"
173SYSTEMD_SERVICE_${PN}-obmc-targets += "${@compose_list(d, 'HOST_ACTION_FMT', 'HOST_ACTION_TARGETS')}"
174
175SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'CHASSIS_LINK_SYNCH_FMT', 'CHASSIS_SYNCH_TARGETS', 'OBMC_CHASSIS_INSTANCES')}"
176SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'CHASSIS_LINK_ACTION_FMT', 'CHASSIS_ACTION_TARGETS', 'OBMC_CHASSIS_INSTANCES')}"
177SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'HOST_LINK_SYNCH_FMT', 'HOST_SYNCH_TARGETS', 'OBMC_HOST_INSTANCES')}"
178SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'HOST_LINK_ACTION_FMT', 'HOST_ACTION_TARGETS', 'OBMC_HOST_INSTANCES')}"
179SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'FAN_LINK_FMT', 'OBMC_CHASSIS_INSTANCES')}"
180SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'QUIESCE_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
181
Patrick Williams9e206392017-01-19 21:20:46 -0600182SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
Andrew Geisslerb2644f82021-02-10 16:11:58 -0600183SRCREV = "75f38ee42d89272d076c20088b37e42b4fffff98"
Patrick Williams9e206392017-01-19 21:20:46 -0600184
185S = "${WORKDIR}/git"