blob: 28f76fed379b58adec9fd8b565228aca9de28b7f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
3implementations."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06004HOMEPAGE = "https://gitlab.freedesktop.org/mesa/piglit"
5BUGTRACKER = "https://gitlab.freedesktop.org/mesa/piglit/-/issues"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "MIT & LGPL-2.0-or-later & GPL-3.0-only & GPL-2.0-or-later & BSD-3-Clause"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
8
Andrew Geisslereff27472021-10-29 15:35:00 -05009SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https;branch=main \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060010 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
Andrew Geissler09209ee2020-12-13 08:44:15 -060012 file://0002-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
Patrick Williams03907ee2022-05-01 06:28:52 -050013 file://0001-CMakeLists.txt-add-missing-endian.h-check.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060014 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040015UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
Andrew Geisslerd5838332022-05-27 11:33:10 -050017SRCREV = "65892137809f7d0d4d7d65dd84af59902b3e7f1e"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018# (when PV goes above 1.0 remove the trailing r)
19PV = "1.0+gitr${SRCPV}"
20
21S = "${WORKDIR}/git"
22
Brad Bishopc342db32019-05-15 21:57:59 -040023X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
24X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
25
Andrew Geissler9aee5002022-03-30 16:27:02 +000026DEPENDS = "libpng waffle libxkbcommon python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027
Brad Bishop6dbb3162019-11-25 09:41:34 -050028inherit cmake pkgconfig python3native features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030# depends on virtual/libgl
31REQUIRED_DISTRO_FEATURES += "opengl"
32
Patrick Williamsf1e5d692016-03-30 15:21:19 -050033# The built scripts go into the temporary directory according to tempfile
34# (typically /tmp) which can race if multiple builds happen on the same machine,
35# so tell it to use a directory in ${B} to avoid overwriting.
36export TEMP = "${B}/temp/"
37do_compile[dirs] =+ "${B}/temp/"
38
Brad Bishopc342db32019-05-15 21:57:59 -040039PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
Brad Bishopc342db32019-05-15 21:57:59 -040041PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
Andrew Geisslereff27472021-10-29 15:35:00 -050042PACKAGECONFIG[vulkan] = "-DPIGLIT_BUILD_VK_TESTS=ON,-DPIGLIT_BUILD_VK_TESTS=OFF,vulkan-loader"
Brad Bishopc342db32019-05-15 21:57:59 -040043
Andrew Geissler09209ee2020-12-13 08:44:15 -060044export PIGLIT_BUILD_DIR = "../../../../git"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045
Patrick Williams213cb262021-08-07 19:21:33 -050046do_configure:prepend() {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
48 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
49 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
50 fi
51}
52
Andrew Geissler82c905d2020-04-13 13:39:40 -050053# Forcibly strip because Piglit is *huge*
Brad Bishop316dfdd2018-06-25 12:45:53 -040054OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060055
Patrick Williams213cb262021-08-07 19:21:33 -050056RDEPENDS:${PN} = "waffle waffle-bin python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040057 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060058 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040059 python3-six python3-shell python3-io \
Brad Bishopc342db32019-05-15 21:57:59 -040060 python3-netserver bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061 "
62
Patrick Williams213cb262021-08-07 19:21:33 -050063INSANE_SKIP:${PN} += "dev-so already-stripped"
Brad Bishop19323692019-04-05 15:28:33 -040064
Andrew Geissler82c905d2020-04-13 13:39:40 -050065# As nothing builds against Piglit we don't need to have anything in the
66# sysroot, especially when this is ~2GB of test suite
Patrick Williams213cb262021-08-07 19:21:33 -050067SYSROOT_DIRS:remove = "${libdir}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050068
Brad Bishop19323692019-04-05 15:28:33 -040069# Can't be built with ccache
70CCACHE_DISABLE = "1"