Brad Bishop | ea02e47 | 2017-05-12 13:02:56 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC event and error logging" |
| 2 | DESCRIPTION = "An error and event log daemon application, and \ |
| 3 | supporting tools for OpenBMC." |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 5 | PR = "r1" |
Patrick Venture | f6dd86b | 2018-10-21 08:22:43 -0700 | [diff] [blame] | 6 | PV = "1.0+git${SRCPV}" |
Patrick Venture | f66d71e | 2018-11-03 09:44:15 -0700 | [diff] [blame] | 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 9 | |
| 10 | inherit autotools pkgconfig |
Matt Spinler | b25f08b | 2020-03-06 09:24:33 -0600 | [diff] [blame] | 11 | inherit python3native |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 12 | inherit obmc-phosphor-dbus-service |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 13 | inherit phosphor-logging |
Marri Devender Rao | 56eae0a | 2017-06-06 08:39:39 -0500 | [diff] [blame] | 14 | inherit phosphor-dbus-yaml |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 15 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 16 | DEPENDS += "autoconf-archive-native" |
| 17 | DEPENDS += "systemd" |
Matt Spinler | 97f809b | 2020-03-13 15:57:29 -0500 | [diff] [blame] | 18 | DEPENDS += "${PYTHON_PN}-mako-native" |
| 19 | DEPENDS += "${PYTHON_PN}-pyyaml-native" |
| 20 | DEPENDS += "${PYTHON_PN}-native" |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 21 | DEPENDS += "${PYTHON_PN}-sdbus++-native" |
| 22 | DEPENDS += "sdbusplus" |
Deepak Kodihalli | c8d9205 | 2017-03-23 03:52:28 -0500 | [diff] [blame] | 23 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 24 | DEPENDS += "virtual/phosphor-logging-callouts" |
Marri Devender Rao | f2ea35d | 2017-05-14 09:01:35 -0500 | [diff] [blame] | 25 | DEPENDS += "phosphor-logging-error-logs-native" |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 26 | DEPENDS += "phosphor-logging-native" |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 27 | DEPENDS += "libcereal" |
Matt Spinler | d981924 | 2019-07-23 16:04:04 -0500 | [diff] [blame] | 28 | DEPENDS += "sdeventplus" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 29 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 30 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 31 | FILES_${PN}-test = "${bindir}/*-test" |
| 32 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 33 | PACKAGE_BEFORE_PN += "${PN}-elog" |
| 34 | FILES_${PN}-elog += "${elog_dir}" |
| 35 | |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 36 | # Package configuration |
| 37 | LOGGING_PACKAGES = " \ |
| 38 | ${PN}-base \ |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 39 | phosphor-rsyslog-config \ |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 40 | " |
| 41 | |
| 42 | ALLOW_EMPTY_${PN} = "1" |
| 43 | PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}" |
| 44 | SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}" |
| 45 | DBUS_PACKAGES = "${LOGGING_PACKAGES}" |
| 46 | |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 47 | FILES_${PN}-base += " \ |
Patrick Venture | 0cf4e35 | 2019-04-04 14:49:25 -0700 | [diff] [blame] | 48 | ${bindir}/phosphor-log-manager \ |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 49 | ${libdir}/libphosphor_logging.so.* \ |
| 50 | " |
| 51 | DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service" |
| 52 | |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 53 | DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service" |
| 54 | FILES_phosphor-rsyslog-config += " \ |
Patrick Venture | 0cf4e35 | 2019-04-04 14:49:25 -0700 | [diff] [blame] | 55 | ${bindir}/phosphor-rsyslog-conf \ |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 56 | " |
| 57 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 58 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Andrew Geissler | 07be1f1 | 2020-04-03 20:02:22 +0000 | [diff] [blame] | 59 | SRCREV = "182071455a82b22e8111217d624c25f4c86dce43" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 60 | |
| 61 | S = "${WORKDIR}/git" |
| 62 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 63 | # Do not DEPEND on the specified packages for native build |
| 64 | # as they will not be available in host machine |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 65 | DEPENDS_remove_class-native = " \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 66 | virtual/phosphor-logging-callouts \ |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 67 | sdbusplus \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 68 | systemd \ |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 69 | libcereal \ |
Matt Spinler | d981924 | 2019-07-23 16:04:04 -0500 | [diff] [blame] | 70 | sdeventplus \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 71 | " |
| 72 | |
| 73 | # Do not DEPEND on the specified packages for native SDK build |
| 74 | # as they will not be available in host machine |
| 75 | DEPENDS_remove_class-nativesdk = " \ |
| 76 | virtual/phosphor-logging-callouts \ |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 77 | sdbusplus-native \ |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 78 | libcereal \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 79 | systemd \ |
| 80 | phosphor-dbus-interfaces \ |
Matt Spinler | d981924 | 2019-07-23 16:04:04 -0500 | [diff] [blame] | 81 | sdeventplus \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 82 | " |
| 83 | |
| 84 | PACKAGECONFIG ??= "metadata-processing install_scripts" |
| 85 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 86 | PACKAGECONFIG[metadata-processing] = " \ |
| 87 | --enable-metadata-processing, \ |
| 88 | --disable-metadata-processing, , \ |
| 89 | " |
| 90 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 91 | # Provide a means to enable/disable install_scripts feature |
| 92 | PACKAGECONFIG[install_scripts] = " \ |
| 93 | --enable-install_scripts, \ |
| 94 | --disable-install_scripts, ,\ |
| 95 | " |
| 96 | |
Matt Spinler | b1c8831 | 2019-08-08 13:21:24 -0500 | [diff] [blame] | 97 | PACKAGECONFIG[openpower-pels] = " \ |
| 98 | --enable-openpower-pel-extension, \ |
Matt Spinler | e64bc0f | 2019-09-26 15:17:15 -0500 | [diff] [blame] | 99 | --disable-openpower-pel-extension, \ |
Matt Spinler | 753951b | 2019-12-18 14:27:07 -0600 | [diff] [blame] | 100 | nlohmann-json nlohmann-fifo cli11 pldm, \ |
Matt Spinler | e64bc0f | 2019-09-26 15:17:15 -0500 | [diff] [blame] | 101 | , \ |
Matt Spinler | b1c8831 | 2019-08-08 13:21:24 -0500 | [diff] [blame] | 102 | " |
| 103 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 104 | # Enable install_scripts during native and native SDK build |
| 105 | PACKAGECONFIG_add_class-native = "install_scripts" |
| 106 | PACKAGECONFIG_add_class-nativesdk = "install_scripts" |
| 107 | |
| 108 | # Disable install_scripts during target build |
| 109 | PACKAGECONFIG_remove_class-target = "install_scripts" |
| 110 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 111 | EXTRA_OECONF = " \ |
| 112 | YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 113 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 114 | " |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 115 | |
| 116 | BBCLASSEXTEND += "native nativesdk" |