blob: 7844a44efdcae38e7f1d26e3f167c1b8bf61f302 [file] [log] [blame]
Brad Bishopea02e472017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylak172fe102016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
Patrick Venturef6dd86b2018-10-21 08:22:43 -07006PV = "1.0+git${SRCPV}"
Patrick Venturef66d71e2018-11-03 09:44:15 -07007LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Adriana Kobylak172fe102016-10-19 14:58:25 -05009
10inherit autotools pkgconfig
Matt Spinlerb25f08b2020-03-06 09:24:33 -060011inherit python3native
Adriana Kobylak172fe102016-10-19 14:58:25 -050012inherit obmc-phosphor-dbus-service
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050013inherit phosphor-logging
Marri Devender Rao56eae0a2017-06-06 08:39:39 -050014inherit phosphor-dbus-yaml
Adriana Kobylak172fe102016-10-19 14:58:25 -050015
Adriana Kobylak172fe102016-10-19 14:58:25 -050016DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
Matt Spinler97f809b2020-03-13 15:57:29 -050018DEPENDS += "${PYTHON_PN}-mako-native"
19DEPENDS += "${PYTHON_PN}-pyyaml-native"
20DEPENDS += "${PYTHON_PN}-native"
Patrick Williams2bebd122020-03-31 16:43:15 -050021DEPENDS += "${PYTHON_PN}-sdbus++-native"
22DEPENDS += "sdbusplus"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050023DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050024DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Raof2ea35d2017-05-14 09:01:35 -050025DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6675eac2017-09-27 10:56:40 -050026DEPENDS += "phosphor-logging-native"
Brad Bishopcc51cd92018-10-18 17:07:53 -040027DEPENDS += "libcereal"
Matt Spinlerd9819242019-07-23 16:04:04 -050028DEPENDS += "sdeventplus"
Adriana Kobylak172fe102016-10-19 14:58:25 -050029
Michael Tritzccc0d0f2017-03-13 14:54:24 -050030PACKAGE_BEFORE_PN = "${PN}-test"
31FILES_${PN}-test = "${bindir}/*-test"
32
Marri Devender Rao6675eac2017-09-27 10:56:40 -050033PACKAGE_BEFORE_PN += "${PN}-elog"
34FILES_${PN}-elog += "${elog_dir}"
35
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050036# Package configuration
37LOGGING_PACKAGES = " \
38 ${PN}-base \
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050039 phosphor-rsyslog-config \
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050040"
41
42ALLOW_EMPTY_${PN} = "1"
43PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
44SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
45DBUS_PACKAGES = "${LOGGING_PACKAGES}"
46
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050047FILES_${PN}-base += " \
Patrick Venture0cf4e352019-04-04 14:49:25 -070048 ${bindir}/phosphor-log-manager \
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050049 ${libdir}/libphosphor_logging.so.* \
50"
51DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
52
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050053DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
54FILES_phosphor-rsyslog-config += " \
Patrick Venture0cf4e352019-04-04 14:49:25 -070055 ${bindir}/phosphor-rsyslog-conf \
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050056"
57
Adriana Kobylak172fe102016-10-19 14:58:25 -050058SRC_URI += "git://github.com/openbmc/phosphor-logging"
Andrew Geissler07be1f12020-04-03 20:02:22 +000059SRCREV = "182071455a82b22e8111217d624c25f4c86dce43"
Adriana Kobylak172fe102016-10-19 14:58:25 -050060
61S = "${WORKDIR}/git"
62
Marri Devender Rao6675eac2017-09-27 10:56:40 -050063# Do not DEPEND on the specified packages for native build
64# as they will not be available in host machine
Brad Bishopefeb13a2018-01-27 00:27:21 -050065DEPENDS_remove_class-native = " \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050066 virtual/phosphor-logging-callouts \
Patrick Williams2bebd122020-03-31 16:43:15 -050067 sdbusplus \
Brad Bishopefeb13a2018-01-27 00:27:21 -050068 systemd \
Brad Bishopcc51cd92018-10-18 17:07:53 -040069 libcereal \
Matt Spinlerd9819242019-07-23 16:04:04 -050070 sdeventplus \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050071 "
72
73# Do not DEPEND on the specified packages for native SDK build
74# as they will not be available in host machine
75DEPENDS_remove_class-nativesdk = " \
76 virtual/phosphor-logging-callouts \
Patrick Williamsa0f4d712020-04-08 10:51:39 -050077 sdbusplus \
Brad Bishopcc51cd92018-10-18 17:07:53 -040078 libcereal \
Brad Bishopefeb13a2018-01-27 00:27:21 -050079 systemd \
80 phosphor-dbus-interfaces \
Matt Spinlerd9819242019-07-23 16:04:04 -050081 sdeventplus \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050082 "
83
84PACKAGECONFIG ??= "metadata-processing install_scripts"
85
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050086PACKAGECONFIG[metadata-processing] = " \
87 --enable-metadata-processing, \
88 --disable-metadata-processing, , \
89 "
90
Marri Devender Rao6675eac2017-09-27 10:56:40 -050091# Provide a means to enable/disable install_scripts feature
92PACKAGECONFIG[install_scripts] = " \
93 --enable-install_scripts, \
94 --disable-install_scripts, ,\
95 "
96
Matt Spinlerb1c88312019-08-08 13:21:24 -050097PACKAGECONFIG[openpower-pels] = " \
98 --enable-openpower-pel-extension, \
Matt Spinlere64bc0f2019-09-26 15:17:15 -050099 --disable-openpower-pel-extension, \
Matt Spinler753951b2019-12-18 14:27:07 -0600100 nlohmann-json nlohmann-fifo cli11 pldm, \
Matt Spinlere64bc0f2019-09-26 15:17:15 -0500101 , \
Matt Spinlerb1c88312019-08-08 13:21:24 -0500102 "
103
Marri Devender Rao6675eac2017-09-27 10:56:40 -0500104# Enable install_scripts during native and native SDK build
105PACKAGECONFIG_add_class-native = "install_scripts"
106PACKAGECONFIG_add_class-nativesdk = "install_scripts"
107
108# Disable install_scripts during target build
109PACKAGECONFIG_remove_class-target = "install_scripts"
110
Deepak Kodihalli44b1c522017-03-16 06:32:12 -0500111EXTRA_OECONF = " \
112 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
113 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
114 "
Marri Devender Rao6675eac2017-09-27 10:56:40 -0500115
116BBCLASSEXTEND += "native nativesdk"