Brad Bishop | ea02e47 | 2017-05-12 13:02:56 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC event and error logging" |
| 2 | DESCRIPTION = "An error and event log daemon application, and \ |
| 3 | supporting tools for OpenBMC." |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 5 | PR = "r1" |
Patrick Venture | f6dd86b | 2018-10-21 08:22:43 -0700 | [diff] [blame] | 6 | PV = "1.0+git${SRCPV}" |
Patrick Venture | f66d71e | 2018-11-03 09:44:15 -0700 | [diff] [blame] | 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 9 | |
| 10 | inherit autotools pkgconfig |
Matt Spinler | b25f08b | 2020-03-06 09:24:33 -0600 | [diff] [blame] | 11 | inherit python3native |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 12 | inherit obmc-phosphor-dbus-service |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 13 | inherit phosphor-logging |
Marri Devender Rao | 56eae0a | 2017-06-06 08:39:39 -0500 | [diff] [blame] | 14 | inherit phosphor-dbus-yaml |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 15 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 16 | DEPENDS += "autoconf-archive-native" |
| 17 | DEPENDS += "systemd" |
Matt Spinler | 97f809b | 2020-03-13 15:57:29 -0500 | [diff] [blame] | 18 | DEPENDS += "${PYTHON_PN}-mako-native" |
| 19 | DEPENDS += "${PYTHON_PN}-pyyaml-native" |
| 20 | DEPENDS += "${PYTHON_PN}-native" |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 21 | DEPENDS += "${PYTHON_PN}-sdbus++-native" |
| 22 | DEPENDS += "sdbusplus" |
Patrick Williams | 997addd | 2020-06-10 06:52:05 -0500 | [diff] [blame] | 23 | DEPENDS += "phosphor-dbus-interfaces" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 24 | DEPENDS += "virtual/phosphor-logging-callouts" |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 25 | DEPENDS += "libcereal" |
Matt Spinler | d981924 | 2019-07-23 16:04:04 -0500 | [diff] [blame] | 26 | DEPENDS += "sdeventplus" |
Patrick Williams | 997addd | 2020-06-10 06:52:05 -0500 | [diff] [blame] | 27 | DEPENDS_append_class-target = " packagegroup-obmc-yaml-providers" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 28 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 29 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 30 | FILES_${PN}-test = "${bindir}/*-test" |
| 31 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 32 | PACKAGE_BEFORE_PN += "${PN}-elog" |
| 33 | FILES_${PN}-elog += "${elog_dir}" |
| 34 | |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 35 | # Package configuration |
| 36 | LOGGING_PACKAGES = " \ |
| 37 | ${PN}-base \ |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 38 | phosphor-rsyslog-config \ |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 39 | " |
| 40 | |
| 41 | ALLOW_EMPTY_${PN} = "1" |
| 42 | PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}" |
| 43 | SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}" |
| 44 | DBUS_PACKAGES = "${LOGGING_PACKAGES}" |
| 45 | |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 46 | FILES_${PN}-base += " \ |
Patrick Venture | 0cf4e35 | 2019-04-04 14:49:25 -0700 | [diff] [blame] | 47 | ${bindir}/phosphor-log-manager \ |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 48 | ${libdir}/libphosphor_logging.so.* \ |
| 49 | " |
| 50 | DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service" |
| 51 | |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 52 | DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service" |
| 53 | FILES_phosphor-rsyslog-config += " \ |
Patrick Venture | 0cf4e35 | 2019-04-04 14:49:25 -0700 | [diff] [blame] | 54 | ${bindir}/phosphor-rsyslog-conf \ |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 55 | " |
| 56 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 57 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Andrew Geissler | 2842e48 | 2021-01-11 19:21:31 +0000 | [diff] [blame] | 58 | SRCREV = "e7d271ae7ecf460b9c4b76caf9ba555f7d8a532e" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 59 | |
| 60 | S = "${WORKDIR}/git" |
| 61 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 62 | # Do not DEPEND on the specified packages for native build |
| 63 | # as they will not be available in host machine |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 64 | DEPENDS_remove_class-native = " \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 65 | virtual/phosphor-logging-callouts \ |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 66 | sdbusplus \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 67 | systemd \ |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 68 | libcereal \ |
Matt Spinler | d981924 | 2019-07-23 16:04:04 -0500 | [diff] [blame] | 69 | sdeventplus \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 70 | " |
| 71 | |
| 72 | # Do not DEPEND on the specified packages for native SDK build |
| 73 | # as they will not be available in host machine |
| 74 | DEPENDS_remove_class-nativesdk = " \ |
| 75 | virtual/phosphor-logging-callouts \ |
Patrick Williams | a0f4d71 | 2020-04-08 10:51:39 -0500 | [diff] [blame] | 76 | sdbusplus \ |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 77 | libcereal \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 78 | systemd \ |
| 79 | phosphor-dbus-interfaces \ |
Matt Spinler | d981924 | 2019-07-23 16:04:04 -0500 | [diff] [blame] | 80 | sdeventplus \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 81 | " |
| 82 | |
| 83 | PACKAGECONFIG ??= "metadata-processing install_scripts" |
| 84 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 85 | PACKAGECONFIG[metadata-processing] = " \ |
| 86 | --enable-metadata-processing, \ |
| 87 | --disable-metadata-processing, , \ |
| 88 | " |
| 89 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 90 | # Provide a means to enable/disable install_scripts feature |
| 91 | PACKAGECONFIG[install_scripts] = " \ |
| 92 | --enable-install_scripts, \ |
| 93 | --disable-install_scripts, ,\ |
| 94 | " |
| 95 | |
Matt Spinler | b1c8831 | 2019-08-08 13:21:24 -0500 | [diff] [blame] | 96 | PACKAGECONFIG[openpower-pels] = " \ |
| 97 | --enable-openpower-pel-extension, \ |
Matt Spinler | e64bc0f | 2019-09-26 15:17:15 -0500 | [diff] [blame] | 98 | --disable-openpower-pel-extension, \ |
Matt Spinler | 753951b | 2019-12-18 14:27:07 -0600 | [diff] [blame] | 99 | nlohmann-json nlohmann-fifo cli11 pldm, \ |
Harisuddin Mohamed Isa | f8a0f29 | 2020-06-05 16:47:37 +0800 | [diff] [blame] | 100 | python3, \ |
Matt Spinler | b1c8831 | 2019-08-08 13:21:24 -0500 | [diff] [blame] | 101 | " |
| 102 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 103 | # Enable install_scripts during native and native SDK build |
| 104 | PACKAGECONFIG_add_class-native = "install_scripts" |
| 105 | PACKAGECONFIG_add_class-nativesdk = "install_scripts" |
| 106 | |
| 107 | # Disable install_scripts during target build |
| 108 | PACKAGECONFIG_remove_class-target = "install_scripts" |
| 109 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 110 | EXTRA_OECONF = " \ |
Patrick Williams | 997addd | 2020-06-10 06:52:05 -0500 | [diff] [blame] | 111 | YAML_DIR=${STAGING_DIR_TARGET}${yaml_dir} \ |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 112 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 113 | " |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 114 | |
| 115 | BBCLASSEXTEND += "native nativesdk" |